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Related Applications or Terminology 

■ Drive Operation Modes – Current / Speed / 
Pulse and Direction 

■ Drive Configuration 

■ Speed Loop Tuning 

■ Position Loop Tuning 

References 

■ MN1919 – MicroFlex Installation Manual 

■ MN1924 – NextMoveESB Installation Manual 

■ AN00124 – Connecting NextMoveESB to a MicroFlex in Current Mode 

■ AN00125 -  Connecting NextMoveESB to a MicroFlex using Pulse and 

Direction 

Overview 

This application note is one of three which together describe the interconnection options for using a 

NextMoveESB and a MicroFlex drive, together with a description of how to configure the motion 

controller and the drive to get simple motion using the different configuration modes. 

There are three different modes of operation available in a MicroFlex drive; Current , Speed and 

Pulse and Direction. Each mode is configured in a different way using different tuning techniques. 

These differences and the benefits of each are described in these documents. This Application Note 

concentrates on Speed mode operation. 

The purpose of this application note is to get a system operational “on the bench”, without a load 

connected to the motor. Some additional comments are added at the end to assist with tuning a 

loaded motor. 

Supported Controllers 

NextMovePCI    ���� 

NextMoveBXII
    ���� 

NextMoveST    ���� 

NextMoveES    ���� 

NextMoveESB ���� 

MintDriveII    
���� 

Flex+DriveII   
���� 

FlexDriveII   
���� 

MicroFlex ���� 

AN00123 - Connecting NextMoveESB to a MicroFlex Drive 
in Speed Mode 
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NextMoveESB Controller 

The NextMoveESB is a programmable 7 axis controller capable of controlling up to 3 axes of servo 

and 4 axes of stepper.  

The unit is programmed using the versatile language 

MintMT which provides a comprehensive set of motion 

instructions for creating motion control programs for 

many types of application. 

This controller provides a very cost effective solution to 

multi axis control applications. 

NextMoveESB has both a RS232 serial port and a USB 

port. Using the USB port will allow communications to 

both the controller and the drive simultaneously if the PC only has one RS232 port. 

 

MicroFlex Drive 

MicroFlex is a sophisticated servo drive which has been designed to meet the 

requirements of multi-axis systems without additional unnecessary features to 

provide high performance in an economical unit. 

The combination of the NextMoveESB and MicroFlex drives is an ideal solution to 

many machine applications and are ideal components for machine builders. 
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Speed Control 

A drive in Speed mode can be used simply to control the speed of a motor, but more typically it is 

used in combination with a motion controller to control the position of the motor. It is most common 

to use Speed mode for position controlled systems as it provides a good dynamic response, a 

reduced risk of erratic behaviour and makes the position loop is far easier to tune for the majority of 

cases. 

A Speed control drive also contains a current controller. The drive receives a speed demand via its 

analog input which is converted into a current demand by the speed controller. The current loop 

then drives current into the motor causing it to accelerate or decelerate.  

The Speed controller is a closed control loop which requires feedback from the motor. A transducer 

fitted to the motor generates a signal which is used to determine the actual speed of the motor. Any 

difference between this and the demanded speed causes a demand on the current controller which 

in turn causes the motor to react to close the gap. Each of these control loops has some associated 

gain terms, each of which require tuning to the system load conditions. 

When a motion controller is added to the system an additional control loop has to be considered, the 

position loop. This also requires suitable feedback which is generated by the motor transducer, fed 

back to the drive and then on to the motion controller. The position loop also has a set of gain terms 

that need to be tuned. 

Feedback Devices 

Motor feedback is essential for accurate “closed loop” control for both the Speed and Position loops. 

There are a number of different feedback devices commonly fitted to motors. For a brushless AC 

servo system it is important that the feedback to the drive provides both absolute positional 

information as well as speed. The positional information is used to commutate the motor and to 

generate an encoder signal passed on to an external motion controller. The speed is derived by 

measuring the rate of change of position (differentiated). 

MicroFlex is compatible with a number of different feedback devices, Hall, Encoder and SSI.  

• “Hall only” feedback may be used for course control although does not generate any signals 

suitable for motion controllers.  

• “Encoder only” requires a “phase search” sequence on power up, the drive will generate an 

encoder signal for use with motion controllers which is simply a buffered copy of the incoming 

feedback signal.  

• “Encoder AND Hall” gives the same level of control and output signals as an “encoder only” 

set up but does not require the “phase search” sequence as absolute information is 

generated by the Hall device.  

• “SSI feedback” provides a high resolution feedback signal that is converted into an encoder 

signal by electronics inside the drive, providing an output for use with motion controllers. The 

resolution of the simulated encoder output is adjustable using the drive configuration 

software. 

• MicroFlex is not compatible with resolver feedback motors. 
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Installing a Simple Speed Drive Positioning System 

Equipment Required – NextMoveESB, MicroFlex Drive, BSM motor with encoder or SSI feedback, 

PC running Windows 2000, XP or later, a serial cable (CBL001-501 or similar), USB or second serial 

cable, Motor power and feedback cables and other interconnecting cables as described below. 

The minimum wiring configuration between drive and motion controller requires an enable signal, a 

demand signal and an encoder feedback signal. Mains power for the drive, 24Vdc supply for the 

drive and controller, a motor power cable and a motor feedback cable connections. Further details of 

these cables are available in the MicroFlex Installation Manual MN1919. 
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Encoder Feedback Cable 

 

 

 

NextMoveESB 

X5 

Function MicroFlex 

X7 

1 CHA+ 1 

6 CHA- 6 

2 CHB+ 2 

7 CHB- 7 

3 CHC+ (index) 3 

8 CHC- (!index) 8 

5 GND 5 

Clamped on 

shell 

Screen Clamped on 

shell 

Analog Demand 

Encoder Feedback 

X3.7  Enable + 
X3.5  DIN0 + 
 
X3.4  DIN0 - 
X3.6  Enable - 
 
 
X2.2  +24V 
X2.1  0V 

X3.13  AIN+ 
X3.12  AIN- 

X7 Encoder Out 

MicroFlex 
NextMove
ESB 

Enable Signal 

Reset signal 

0V 

Demand0  X13.1 
AGND  X13.2 

 
Shield  X13.3 

Encoder0 X5  

DOUT0  X11.1 
DOUT1  X11.2 

 
USR V+  X11.9 

USR GND  X11.10 
 

24V IN  X1.2 
0V IN  X1.1 

 

24V 

Electrical Connections between NextMoveESB and MicroFlex 
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Making a Communications Link 

During the configuration of the MicroFlex and the NextMoveESB it will be necessary to switch the 

communications link between the devices. If only one serial port and no USB connection is available 

then a single copy of WorkBench v5 must be used; each time you need to communicate with a 

different device you must physically move the connection between controls, this is referred to as a 

single port setup. If two serial ports are available or a serial port and a USB port then two copies of 

WorkBench v5 can be run at the same time, this is the dual port setup. 

Connecting to NextMoveESB 

Make sure there is 24V power applied to the NextMoveESB and the LED status display is illuminated. 

• Connect the serial or USB cable to the 

appropriate NextMoveESB port  

• Run WorkBench v5 

• Select Start New Project  

• Choose the USB or COM port that the 

MicroFlex is connected to 

• Click the Scan button 

• Select the NextMoveESB when it appears 

in the list. 

• Save the connection settings using File > 

Save Project, call the file NMESB.WBX 

 

Note: WorkBench v5 project files contain 

information about your application, including: 

• Information about the controller that is 

currently connected. 

• Links to the program files (.mnt file). But NOT the actual program file. 

• Other desktop details. 

 

The project file does not contain any program code - it is contained in the separate .mnt files. 

Always remember to “Save File” after making any program changes. 

It is important that there is no program in the NextMoveESB when configuring, as settings from a 

different system may cause unexpected behaviour. To delete a program, select the menu option 

Program > Delete Existing. Then select Tools > Reset Controller to set factory default settings. 

Next we will connect to the MicroFlex so for a single port configuration close down WorkBench v5, 

for a dual port system keep this copy of WorkBench v5 running. 
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Connecting to MicroFlex 

 

• Make sure MicroFlex has 240Vac and 24Vdc 

applied. 

• For a single port configuration move the serial 

connection to the MicroFlex 

Or  

For a dual port system connect the serial lead 

between a second PC COM port and the 

MicroFlex connector labelled X6 or connect the 

USB cable. 

• Run WorkBench v5 

• Choose the port that the MicroFlex is connected 

to. 

• Click the Scan button, MicroFlex should be 

detected and the connection details will appear 

in the list 

• Make sure the Launch Commissioning Wizard box is checked, (the Commissioning Wizard is a 

tool used to display and edit many of the drive settings which can be configured one page at 

a time. Do NOT reselect the MicroFlex from the list.) 

• Click Select to make the connection to MicroFlex. 
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MicroFlex Commissioning Wizard 

The Commissioning Wizard shows a sequence of screens displaying the appropriate drive settings 

and requesting information required to commission the drive. When each page is complete click the 

Next button to continue through the Wizard. 

Welcome Page 

The first screen describes the process and offers the opportunity to set all drive parameters to their 

factory setting. Make sure the Reset Factory Defaults box is checked and click the Next button. 

Motor Type / Select Motor 

Select the correct motor type, usually this is done using the catalogue number printed on the motor 

name plate. Be sure to copy the exact product code. The Spec number can also be used to identify 

the motor. 

Feedback 

Encoder motors have a fixed resolution, this cannot be changed, SSI motors have a user selectable 

resolution. Usually it is good to select the highest resolution available unless the application requires 

long travel distances or high speeds. (Refer to the help file for the limitations of distance and speed) 

Operating Mode 

For the operating mode select “SPEED Control” 

Current Control 

The Current control page settings do not normally need to be adjusted, but make yourself familiar 

with the parameters available for adjustment later. Pressing F1 will bring up help on these topics. 

Speed Control 

On the Speed control page the only parameter that generally needs to be modified is the 

“Application Max Speed”. At this point it is necessary to have a feel for how fast the motor is 

required to move for the application. If you have no idea then the default speed of 3000 will be a 

good starting point. If the application requires a speed in excess of the value typed here then it will 

not be able to attain the demanded speed and a following error will probably be created. This will 

need correcting later and the system retuned. 

Be aware that the maximum speed is limited both by the available bus voltage and the motor’s 

physical maximum speed, therefore the speed entered at this point cannot exceed either of these 

two values which are displayed for your reference.  

For applications that are designed to run at slower speeds it is advisable that the “Application Max 

Speed” is reduced to maximise on the speed resolution available, this will improve speed accuracy at 

lower speeds. But always set this parameter to a value slightly in excess of the maximum required 

to avoid unwanted errors. 

For control by the NextMoveESB the “Source of Speed Demand” should be “Analog Input 0 – 

Profiled”. This is the default value and should not need to be changed. 
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Step and Direction Control 

For Speed Control the Step and Direction parameters are not applicable so no need to change 

anything on this screen. 

Digital I/O 

The digital inputs should be configured to be “Level triggered”, “Active High” (or set in accordance 

with the application’s requirements) 

The programmable input should be set to be the Reset Input (or set in accordance with the 

application’s requirements) 

Analog Inputs 

The analog input does not normally need any parameter setting with the exception of the Offset 

Compensation. Click the Offset Tune button to activate the routine to zero the analog input. The 

NextMoveESB demand should be connected at this point and demanding zero speed (this is its 

default condition). The offset value should be a small percentage (between -1% and +1%), if not try 

again making sure there is no demand from the Motion Controller. 

Save Settings 

Remember to save the parameters when prompted to do so as MicroFlex parameters are not saved 

automatically. To do this manually select the menu option Tools > Save Drive Parameters or click 

the Save button. 

At this time you can also save the connection details as a project, from the menu options select File 

> Save Project, choose a suitable folder to save the information and give it the name MicroFlex.WBX 
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Switching Communication Between Devices 

Throughout the configuration section of this document you will be instructed to “switch to MicroFlex” 

or “switch to NextMove”.  

To switch with a single port system – Move the serial connector from one device to the other, in 

WorkBench v5 select File > Open Project, and select either the MicroFlex.WBX or NMESB.WBX 

project file to make the appropriate connection.  

To switch using a dual port system – simply toggle to the other copy of WorkBench v5. 

Tuning MicroFlex 

Before the tuning process can be started it is necessary to ensure that any brake fitted to the motor 

is released and an enable signal is provided to the MicroFlex from the NextMoveESB.  

If a brake is fitted to the motor make sure 24V is applied and check that the motor shaft is free to 

turn. If the brake is to be controlled by the NextMove follow the instructions below for providing the 

enable signal, except select the appropriate output number or use the RELAY command. 

Switch the communications link to the NextMove. 

 

When connected, choose the Application toolbox folder on the left edge of the 

WorkBench window. 

 

 

 

 

 

Click on the Edit and Debug icon 
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Here you will find the terminal and the command line windows. 

 

 

To issue single commands to the controller use the command line window and type the following: 

OUTX(0) = 1  This command provides the enable signal 

OUTX(1) = 1  Either of these commands can be used  

RELAY = 1     to release a motor brake 

This will turn on digital output 0 and provide the enable signal to the MicroFlex drive. The drive may 

not enable immediately as it is probably software disabled at this stage but this is not a problem. 

To continue with the tuning you will now need to switch back to MicroFlex and go back to the 

Autotune screen. 
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Autotuning 

To begin with it is always advisable to AutoTune the system with the motor disconnected 

from the load. This ensures that the system is functioning correctly before moving the load 

and reduces the risk of causing damage. This application note assumes the motor is 

unloaded and free to rotate in either direction. 

If you are using a standard Baldor motor selected from the database and the wiring is correct, it 

should only be necessary to complete the recommended Autotuning steps:- Calculate current loop 

gains, Measure the motor inertia, Calculate the speed and position gains.  

• Click the START button to proceed. 

Once the Autotuning is complete remember to save the drive parameters when prompted.  

If Autotuning fails, selecting the other tuning options may correct some simple wiring or 

configuration faults. If the errors continue to be generated check the wiring carefully and refer to the 

help files for more assistance on Autotuning errors. 

Fine Tuning 

The Fine tuning screen can now be used to check the performance and 

modify the response if required. As the drive has been configured in 

Speed mode we will perform a test speed move. Make sure the Speed 

tab at the bottom right corner of the WorkBench v5 screen is selected.  

A suggested test move would be to set up a bi-directional, 40% speed 

move for 1 second. Click the Go button when these parameters have 

been typed in and you are ready to start the move. When the move is 

complete and the graph is displayed look at the Speed Measured and the 

Speed Command Demand, hopefully these will show a reasonable match. 

If there is some overshoot it can be easily reduced by decreasing the 

value of Tracking Factor (KVTRACK). Then try the move again. Other 

gain terms can be easily adjusted using the Calculate button and using 

the Bandwidth slider to increase or decrease the response of the motor. 

After each change to the settings try the test move again to see if there 

has been an improvement. 
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In the example plot above the Tracking Factor has been reduced from 100 to 80 to decrease the 

overshoot seen at the ends of the acceleration and deceleration periods. 

Once the tuning step is complete the drive is ready to be controlled by the NextMove. Make sure the 

drive parameters are saved (Tools > Save Drive Parameters). Also make sure that the drive is 

software enabled. To software enable the drive click the Enable icon on the toolbar. 

 

 Warning! Be aware the motor could “run off” at high speed or may drift slightly. 

Do not worry about a slow drift of the motor, this is normal and will stop when the position loop is 

enabled. If the motor moves out of control click the Enable icon again to disable the drive, then 

check the connections and that a program is not running on the NextMove. 
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Setting Up NextMove 

Switch to NextMove. 

Before we can start position loop tuning it is necessary to check that all of the connections are 

correct and that the signals are working in the correct sense. Using WorkBench v5 connected to 

NextMove select the Edit & Debug page and type the following instructions at the Command Line. 

To enable the drive type the following 

 

 

 

 

 

 

 

 

We are ready to try to move the motor, ensure there are no obstructions and that the motor is free 

to turn with the brake released. If the motor moves out of control be ready to click the Enable icon 

on the WorkBench v5 Toolbar to disable the drive.  

 

 

Now type the following at the command line: 

 TORQUE(0) = 1 

 

The value displayed in the Position Counter should be increasing, this indicates that for a positive 

demand the motor counts in a positive direction. The measured Speed should also be a positive 

value. 

Try: 

 TORQUE(0) = -1 

 

The motor should reverse its direction, Speed should have a negative value and the position counter 

should count down.  

To stop the motor type: 

 CANCEL 

This is an important test to do before enabling the servo loop and adding any gain values. If the 

direction of count is the opposite to the demand then the motor will “run off” uncontrollably. If the 

count is in the wrong direction then the wiring should be checked, however it is also possible to 

reverse the direction of the count using the following Mint command 

CONFIG([0,1,2,3,4,5,6]) = _cfOFF; 

CONFIG(0) = _cfSERVO 

DRIVEENABLEOUTPUT(0) = 0 

FOLERRORMODE(0) = 0 

RESETALL  

TORQUE(0) = 0 

 

Axes have default connections so must be 
turned off before re-configuration as servo 
axes. 
Set output 0 to be the drive enable output 
Turn off following error detection 
Clear any errors on all axes and enable the 
drive 
Demand an open loop speed demand of 0 
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ENCODERMODE(0) = 1 ‘reverse encoder direction, (= 0 for forward 

direction) 

Reversing the Motor Direction 

If the count is in the right sense but the motor is physically moving in the wrong direction for the 

application, the following commands can be used to reverse the motor direction: 

DRIVEENABLE(0) = 0 ‘Disable drive 

DACMODE(0) = 16  ‘reverse demand direction, = 0 for forward direction 

ENCODERMODE(0) = 1 ‘reverse encoder direction, = 0 for forward  

                          direction 

            DRIVEENABLE(0) = 1 ‘Enable drive 

 

Remember it is important that the position counter counts up for a positive TORQUE value and 

counts down for a negative TORQUE value. The physical direction that the motor moves is not 

important for servo control. Always check the direction of feedback after making these changes. 

To stop the motor moving type the CANCEL command.  

Setting Scale Factor 

To define motion in terms of useful units it is normal to set a scale factor. The scale is calculated by 

determining the number of encoder counts per user unit. In the case of an unloaded motor useful 

units would be motor revolutions (revs), in this case SCALE = number of encoder counts per rev 

 SCALEFACTOR = 4000 (for a standard encoder motor) 

 SCALEFACTOR = 262144 (for a SSI motor set to its maximum resolution) 

 

You can set the scale factor at the command line. 

 

  Note 

MintMT has an abbreviation for most of the keywords which is useful when typing at the command 

line as it reduces the amount of typing required. A few are listed below 

DRIVEENABLEOUTPUT = DEO  SCALEFACTOR = SF 

RESETALL = RA   DRIVEENABLE = DE 

TORQUE = TQ 

PRINT = ? 

These commands, and others, are all described in more detail in the WorkBench v5 Help files. Help 

can be obtained by pressing F1 with the cursor positioned on a MintMT keyword in the command 

line.  

The use of abbreviated commands is not recommended for use in a program, it makes the code very 

difficult to understand at a later point in time or by other people. 
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Position Loop Tuning in NextMove 

As there is no Autotuning facility for the position loop on NextMove controllers, the gain terms need 

to be either calculated or determined experimentally. The Fine-tuning screen is the ideal tool to set 

the gains and test the response.  

To tune the position loop on the NextMove we start by setting two gain terms, KPROP and KVELFF. 

The value for KVELFF can be calculated from the configuration of the drive. 

KVELFF =  2048 x (Number of loop closures per second) 

          Max Speed(rps) x Encoder Resolution (cpr) 

Number of loop closures per second is set using the LOOPTIME command. This is 1000µs (1ms) by 

default which gives 1000 loop closures per second. (1 / 0.001 = 1000) 

The max speed is defined in the drive’s Application Max Speed Setting (default 3000rpm). To 

convert from rpm to rps divide by 60, eg 3000rpm = 50rps 

The encoder resolution is also defined in the drive settings as the simulated encoder output 

resolution. It is the value in counts per rev (4 x pulse count) that is required, for example a 1000 

line encoder will give 4000 counts per second due to the effects of quadrature.  

Using the default values  

KVELFF = 2048 x 1000  = 10.24 (KVELFF = 0.156 for SSI with max resolution) 

         50 x 4000 

If your settings are different, use these values in the calculation to determine the correct value for 

KVELFF for your system. Clearly if any of thee parameters are changed on the drive then a new 

value for KVELFF needs to be calculated. 

The value of KPROP (Proportional Gain) is normally determined experimentally. This means you 

need a starting point, a value of 0.1 is appropriate for most systems. 

To test these values you need to define a suitable test move. Provided your motor is still unloaded it 

should be safe to make a move, a profile lasting about 1s is ideal. It is also best to choose 

accelerations and speeds that define a trapezoidal profile shape. In the Fine-tuning screen on the 

Position tab type in the following values which are suitable if scaled in Revs: 

Speed = 30 (rps) 

Acceltime = 100 (ms) 

Deceltime = 100 (ms) 

Distance = 30 (revs) 

These values give a move time of 1.1s 

Make sure the KPROP and KVELFF values have been typed in correctly and click the GO button. 

The motor will perform the move and the captured data will be uploaded and displayed on the 

screen. If the motor vibrates excessively then the starting value for KPROP could be too high; this is 

more likely with high resolution systems. Try a smaller value of KPROP like 0.01. 
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In this diagram the 

trapezoidal shaped line (in 

green) is the measured 

velocity trace and the “S” 

curve (blue) line is the 

measured position. It is also 

possible to turn on and off 

the Demanded Velocity and 

the Demanded Postion, the 

objective of tuning is to get 

the measured line to follow 

the demanded line as closely 

as possible. 

 

 

 

 

 

 

 

To fine-tune the gain terms it is best to look at the difference between the measured position and 

the demanded position, known as the following error. To see this on your graph make sure all other 

plots are turned off by unchecking the check boxes. 

 

 

This is a typical plot of following error for a 

trapezoidal move. The peaks at the beginning and 

ends of the profile represent the acceleration and 

deceleration periods. The flat area in the centre is 

the constant speed section. Adjusting KVELFF will 

move the flat line up and down, the ideal is zero. 

This can be used to fine tune KVELFF. If the 

calculation has been done correctly only very small 

changes will be required (0.01 at a time) 
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Increasing KPROP will reduce the magnitude of the peaks during acceleration and deceleration, 

however an excessive value is likely to introduce oscillations. To fine-tune KPROP gradually increase 

its value, repeating the test move each time, until the peaks reduce in size or oscillations in the 

response start to appear. At this point the value should be reduced a little until no oscillation is 

observed. Another simple check is to hold the motor shaft to make sure it is stiff and does not 

vibrate after tuning with the test moves and plots. If a vibration is felt, reducing the value of KPROP 

is recommended. 

Other gain terms can be added to improve the response, but this is beyond the scope of this 

document. Please refer to the manuals and help files for more information. 

When the tuning is complete it is advisable to turn the Following Error Detection back on, without 

this it is possible to build up very large following errors which may result in the motor running off 

out of control. Use the command 

   FOLERRORMODE(0) = 1 

Creating a Program 

The NextMove is now configured and ready for programming. The first thing to do to create a 

program is to include all of the settings made during the configuration. WorkBench v5 makes this 

very simple. In the Edit & Debug screen use the File > New File menu option to create a new blank 

program. Then select Tools > Upload Configuration Parameters, to create a Startup block in your 

program containing all of the settings made during the configuration process. 

The following is a very simple test program which can be typed in above the Startup block code of 

your program. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

'Test program for NextMoveESB 

Auto   ‘Runs program on powerup of controller 

RESETALL   ‘Clears errors and enables drive 

 

HOMESPEED(0) = 10 ‘Sets the homing speed to 10 rps 

HOMEBACKOFF(0) = 3 ‘Sets the backoff speed to 10/3 rps 

HOME.0 = _hmNegative_Index ‘Move axis to index pulse in a negative 

direction then zero the position 

counter 

Pause IDLE(0)  ‘Wait for motion to stop 

 

Loop   ‘Set up a never ending loop 

  MOVER(0) = 10 ‘Move axis 0 10 revs from current position 

  GO(0)   ‘Start move 

  MOVER(0) = -10 ‘Move axis 0 back to its start position 

  GO(0)   

  Pause IDLE(0) ‘Wait for motion to stop 

End loop   ‘Terminate Loop 
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This code assumes that the preceding set up process has been completed and that no load is 

connected to the motor. If this code is to be used after connecting a load then the Scale, 

Speeds and Distances will probably need to be changed. 

Connecting a Load 

When every part of the system has been tested and is working correctly it is time to connect the 

load. This will require some parts of the servo system be re-commissioned. The drive will need re-

tuning, the controller will need the position loop be re-tuned, the scale factor will probably change, 

the IO may need configuration etc. 

To re-tune the drive the NextMove must supply an enable signal but the position loop should be 

disabled. The easiest way to do this is to type 

TORQUE(0) = 0 

Switch communications to MicroFlex and select the Fine-tuning screen. With the motor load 

connected simply click the Measure button to determine the new load inertia, followed by the 

Calculate button to create new gain terms. Fine tuning can then be carried out as before, adding an 

appropriate Accel and Decel Time is normally beneficial when tuning loaded motors as a step 

response is very difficult to achieve. Be very careful not to move too far or too fast during the test 

moves. It is always best to start with slow short moves and increase until a reasonable motion 

profile is attained. 

To tune the NextMove after the load has been fitted, switch to the NextMove and repeat the tuning 

section. The KVELFF should not change its value but the KPROP may need to be modified. Again 

make sure any test moves do not exceed the limits of travel. Using scaled units may make this 

easier. Recalculate the scale factor to represent the mechanical system connected to the motor, use 

units appropriate to the type of movement (mm for linear travel, degrees or revs for rotary travel). 

Remember that scale factor is calculated as: 

SCALEFACTOR =  Number Of Counts per User Unit 

 

When the tuning and reconfiguration is completed, remember to upload the changes into the Startup 

block by selecting Tools > Upload Configuration Parameters from the toolbar menu. 

 

At this point it is a good idea to save the program in the NextMove and the parameter file from the 

MicroFlex. When connected to the NextMove and in the Edit & Debug screen select File > Save File, 

find a suitable folder on the computer and give the program a name “Test Program.MNT” for 

example. Note - Selecting Save Project will NOT save the Mint program. 

Connect to the MicroFlex, select Tools > Parameter Table > Upload, find a suitable folder on the 

computer and give the parameter file a name “Axis 0 Settings.PTX” for example. 

Your system should now be ready to run and work can start on commissioning the application 

program. 


